3 Gentoo Updates
Posted on: 11/13/2013 04:01 PM

The following 3 Gentoo Linux updates has been released: [ GLSA 201311-09 ] FreeRADIUS: Multiple vulnerabilities, [ GLSA 201311-08 ] Netpbm: User-assisted arbitrary code execution, and [ GLSA 201311-07 ] Blender: Multiple vulnerabilities

[ GLSA 201311-09 ] FreeRADIUS: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201311-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: FreeRADIUS: Multiple vulnerabilities
Date: November 13, 2013
Bugs: #339389, #386183, #434802
ID: 201311-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in FreeRADIUS, the worst of
which allow execution of arbitrary code or Denial of Service.

Background
==========

FreeRADIUS is an open source RADIUS authentication server.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-dialup/freeradius < 2.2.0 >= 2.2.0

Description
===========

Multiple vulnerabilities have been discovered in FreeRADIUS. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All FreeRADIUS users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-dialup/freeradius-2.2.0"

References
==========

[ 1 ] CVE-2010-3696
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-3696
[ 2 ] CVE-2010-3697
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-3697
[ 3 ] CVE-2011-2701
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2701
[ 4 ] CVE-2012-3547
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3547

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201311-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201311-08 ] Netpbm: User-assisted arbitrary code execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201311-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Netpbm: User-assisted arbitrary code execution
Date: November 13, 2013
Bugs: #308025
ID: 201311-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Netpbm could result in execution of arbitrary code
or Denial of Service.

Background
==========

Netpbm is a toolkit for manipulation of graphic images, including
conversion of images between a variety of different formats.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/netpbm < 10.49.00 >= 10.49.00

Description
===========

A stack-based buffer overflow exists in converter/ppm/xpmtoppm.c in
Netpbm.

Impact
======

A remote attacker could entice a user to open a specially crafted XMP
file using Netpbm, possibly resulting in execution of arbitrary code
with the privileges of the process, or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Netpbm users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/netpbm-10.49.00"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

References
==========

[ 1 ] CVE-2009-4274
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2009-4274

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201311-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201311-07 ] Blender: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201311-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Blender: Multiple vulnerabilities
Date: November 13, 2013
Bugs: #219008, #293130
ID: 201311-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Blender, the worst of which
could allow attackers to execute arbitrary code.

Background
==========

Blender is a 3D Creation/Animation/Publishing System.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-gfx/blender < 2.49b-r2 >= 2.49b-r2

Description
===========

Multiple vulnerabilities have been discovered in Blender. Please review
the CVE identifier referenced below for details.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process, or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Blender users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/blender-2.49b-r2"

References
==========

[ 1 ] CVE-2008-1102
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2008-1102
[ 2 ] CVE-2008-1103
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2008-1103
[ 3 ] CVE-2009-3850
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2009-3850

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201311-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/3_gentoo_updates_b2ae.html)